The installation process of a full-operational seismic processing machine is split in three main parts:
  1. Seismic processing packages, like Seismic Un*x, Madagascar, ToSCo, etc.
  2. GêBR suite (GêBR client, server, DéBR).
  3. Menus to turn installed seismic processing packages visible to GêBR.

Installing seismic processing packages

The most common seismic processing package employed by GêBR users is Seismic Un*x (SU), since it is completely integrated with GêBR. Instructions about how obtain and install SU are available in its official site. However, as a cortesy, the GêBR Project offers a simple tool to go through all steps of the installation process of SU. This tool is designed and tested only for Ubuntu (see this post).

Install instruction for other seismic processing packages should be looked for in their own sites.

Installing GêBR suite and menus

The GêBR Project provides support to the last three releases of Ubuntu, to the last three releases of Fedora, to the stable version of Debian, and to CentOS 4, 5 and 6, at least.

There are several ways to install GêBR. For users with supported Linux distributions, the simplest one is adding the GêBR repository to your system and let the package manager take care of the rest.

Follow the specific instructions for your Linux distribution: Ubuntu, DebianFedora / CentOS.

Installing from binary packages

This method should be used in case you did not manage to configure your system to employ the repository.

  1. Download the appropriate package for your system, from download area.
  2. For deb packages run:

    dpkg -i *deb

    For rpm packages run:

    rpm -Uhv *rpm

Despite its simplicity, this method neither allows automatic upgrades upon new releases, nor solve dependency problems.

Install from source code

In case you have a different linux/unix distribution, not based on deb or rpm package format, attempt to install from source codeGêBR has some dependencies, namely:

  • glib 2.20.0 or higher
  • GTK+ 2.18.0 or higher
  • libgdome 0.8.0 or higher
  • libgthread 2.22.0 or higher
  • libgobject 2.22.0 or higher
  • libwekit 1.0.1 or higher